Skip navigation

My configuration is a 64bit version of Fedora 13 running as a virtual machine on a Windows 7 64bit host.

Over the weekend I had the joy of setting up a Panda Board for the first time. I got it working for the most parts with a few quirks. I was following the wiki form omappedia on how to set up validationfs on the PandaBoard. After downloading the filesystem I extracted it to ” “/home/s/pandaFS” and got a boot folder and another tar.gz file, thinking that was weird I extracted the second tar.gz to the same folder (first mistake, will explain why later).  Continuing to follow the instructions I copy the contents of the /home/s/pandaFS/boot folder to the mounted partition of the SD Card. After reading the the file system part I went oo I didn’t need to extract the extract the second tar.gz to this location I could have left it and extracted it to the second partition, silly me.

I now have my validationfs setup and ready to go, or so I think, I connect everything to my PandaBoard and I am ready to go. I run “sudo minicom -s” and configure it to listen to /dev/ttyUSB0 where dmesg tells me my usb to serial dongle is, I save this as the default and off I go. My progress stops short when I encounter the error “Cannot open /dev/ttyUSB0: Invalid argument”  I was like strange maybe this new dongle doesn’t work, so I try again with a dingle that I know works I get the same error message. I switch to Windows and try the dongles using putty and teraterm but I dont get any input from the line.

My next train of thought is that something must be wrong with the way i built the SD card. So I go about redoing the process and decide extract the validationfs to a different directory I then compared the contents of the boot folder of the new extraction to the old and notice they where different. Bringing me back to my first mistake, when i extracted the filesystem tar.gz into the same folder initialy it over wrote some of the contents of the first some so when I copied it over it failed miserably when trying to boot. So I fixed that issue and tried to boot again, staying in windows using putty initially when booting I was now getting information on the serial line but it was not readable, tried teraterm next to see if it was a encoding issue that would be fixed by a different program, no it was not so back to minicom on my Fedora virtual machine I went.

Now that I had confirmed that both dongles work I started minicom and to my dismay I got the same error “Cannot open /dev/ttyUSB0: Invalid argument”, I connected the second dongle and tested to only now get the error Cannot open “/dev/ttyUSB1: Invalid argument” after many hours of google and testing configurations and testing on other virtual machines i still get the same error. When I was close to giving up after a reboot of my host. I then connected the 2 dongles to the vm at the same time tried ttyUSB0 it failed, tried ttyUSB1 and  to my surprise it worked. I was now able to see the prompt for the panda board I was so happy. So now i shutdown the PandaBoard and connect all the peripherals and turn on the board and it successfully completes all tests.

Figuring everything is good I load the minimalfs onto the the second partition of the SD card. I works I see the command prompt on  y serial connection it works I am happy to then find out I am not getting a image on my monitor (Samsung SyncMaster T220HD).  It isn’t to say that it doesn’t detect it because I don’t get the no cable signal error on the screen. I run the monitor tests that the validaitonfs used and it displays the test correctly but not the prompt. After some more time with my best friend google and testing some other settings I cant get it work but since my project doesnt require a GUI I was satisfied that i didnt get it up.

A couple of days later I decided to test the usb dongle when the machine was running Fedora as the host. I boot up into a live CD and attach the dongle, install minicom, configure it to use the usb dongle  and it worked just like that. So for now I am going to use a retired laptop for my PandaBoard testing hoping that it can survive with out overheating.

 

Advertisements

One Comment

  1. Your weblog appears to be having some compatibilty issues in my internet explorer browser.
    The text seems to be running off the page pretty bad.
    If you want you can e-mail me at: rosalinda_holloman@t-online.de and I will shoot you over a screen shot of the problem.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: